Discovered issues with collection export feature
Incident Report for Postman
Resolved
This issue has been resolved.

Affected versions: v6.2.1, v6.2.2 & v6.2.3
Fix version: v6.2.4

GitHub issue: https://github.com/postmanlabs/postman-app-support/issues/4952
Posted 2 months ago. Aug 10, 2018 - 06:52 UTC
Monitoring
We've released Postman v6.2.4 for all users which includes the fix for this issue. Please update via Settings > Update > "Check for updates" and let us know if the issue is resolved at your end via the GitHub issue - https://github.com/postmanlabs/postman-app-support/issues/4952.
Posted 2 months ago. Aug 09, 2018 - 13:33 UTC
Update
While monitoring the canary version (v6.2.4-canary01), we identified that another bug fix that was targeted for v6.2.4 stable release was unstable. We have reverted that bug fix and have released v6.2.4-canary02. We are monitoring this new version and would share an ETA on the rollout to stable channel by today 12pm UTC.
Posted 2 months ago. Aug 09, 2018 - 05:41 UTC
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Aug 08, 2018 - 13:53 UTC
Update
We've fixed this issue and have released a patch version (v6.2.4-canary01) on our canary channel (https://www.getpostman.com/canary). We are monitoring the stability of this version and will share an ETA on the rollout to stable channel by today 12pm UTC.
Posted 2 months ago. Aug 08, 2018 - 08:07 UTC
Identified
We've identified an issue with collection export feature in Postman Native app versions v6.2.1, v6.2.2, and v6.2.3. Exports to Collection v2.0 and Collection v2.1 formats in these app versions have an additional "_postman_id" field included with every request and folder in the collection. This will not affect the collection from being exported or from being imported into other versions of the Postman app. But we are aware that this issue adds significant friction to workflows that include checking in exported collections into version control systems.

We've identified and isolated the issue to a change in a library we use in the Postman app. We're working on fixing this and release the fix in a patch release this week.

Related GitHub issue: https://github.com/postmanlabs/postman-app-support/issues/4952
Posted 2 months ago. Aug 07, 2018 - 12:49 UTC
This incident affected: Postman App.